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CHAPTER 1 

Overview 

The 3M™ MicroTouch™ Software Diagnostic Utility (SDU) enables you to troubleshoot 
your 3M Touch Systems sensor and controller. The minimum system hardware 
configuration requirement to run the Software Diagnostic Utility (SDU) is a system 
running a 200 MHz processor with 32 Mb RAM with Windows XP or better. 

The Software Diagnostic Utility (SDU) can run directly to the serial port or through the 
3M MicroTouch MT7 Software driver. 
 

 Microsoft Windows XP/Vista/Windows 7 
Serial Direct to port or through the MT7 Software driver 

USB Through MT7 Software driver 

HID Direct through Microsoft driver or MT7 software 

The Software Diagnostic Utility (SDU) requires a keyboard and mouse. 

3M Touch Systems Support Services 
3M Touch Systems, Inc. provides extensive support services through our website and 
technical support organization. Visit the 3M Touch Systems website at 
http://www.3m.com/touch, where you can download touch software and drivers, obtain 
regularly updated technical documentation on 3M Touch Systems products, and learn 
more about our company. 

Whenever you contact Technical Support, please provide the following information: 
• Touch display size, part number and serial number 
• Current driver version 
• Operating system used 
• Information on additional peripherals 

Technical Support is available Monday through Friday 8:30 a.m. to 5:30 p.m. with 
limited call back service after 5:30 p.m. until 8:00 p.m. US Eastern Standard Time – 9 
a.m. to 5 p.m. throughout Europe.  
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You can contact 3M Touch Systems, Inc. Technical Support (US only -- Eastern 
Standard Time) by calling the hot line, sending email or a fax. 
• Technical Support Hot Line: 978-659-9200 
• Technical Support Fax: 978-659-9400 
• Toll Free: 1-866-407-6666 (Option 3) 
• Email: US-TS-techsupport@mmm.com 

Contact 3M Touch Systems 
Contact information for all offices can be found on our website at: 
http://www.3m.com/touch 
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CHAPTER 2 

File 

 

Toggle Logging On/Off 
This option is a data collection function. You can log raw data from the sensor corners to 
troubleshoot sensor performance. This feature is most often used for automated testing, 
stray capacitance, and noise profiling.. 

When first opened, a dialog box will open and request a file name and location. You can 
log raw data in the background even when other non-logging tools are running. 

To begin logging select File > Toggle Logging On/Off. A Log indicator is displayed in 
the lower right corner of the status bar whenever the log file is open. This appears in the 
lower right corner of the active window. Since everything writes to the same log file, 
only one tool should be actively logging.  

View Log File 
Use this option to open the log file you created. 

Exit  
Exit the Software Diagnostic utility. 
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CHAPTER 3 

Edit 

 

Copy 
In Terminal mode, the text buffer is copied to the clipboard. 

In Draw mode, the screen image is copied to the clipboard. (Similar to Alt-PrintScrn) 

The saved text or image can then be pasted into another file for record keeping. 

Paste 
Pastes the copied text or image into another file for record keeping. 

Select All 
Selects all text on the screen – this is not an image of the screen if in split screen mode. 

Clear All 
Clears the viewable screen -- any text or draw images. 
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CHAPTER 4 

Port 

 

Open Com 1  
This option shows all available serial COM ports. Use this feature to select the touch 
controller serial COM port on the Host system. This feature is also used to report the 
communication parameter information for this port, i.e., Baud rate, Parity, Data Bits, and 
Stop Bits. The figure below shows standard 3M Touch Systems operating mode. 
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Use the menu radio buttons to select the desired Windows COM port. If the port is 
available, you can select the appropriate parameters. 

If you get a “Can’t Open Port” message, it either means that there is no such port or that 
some other application (that includes MT7 Software) owns the port.  

Depending on the firmware, the SDU will look for a touch driver and connect to it. If it is 
Serial, the COM Port status bar indicates which serial port and baud rate the driver is 
using.  

If the SDU displays “Can’t Connect to Driver” and you know that there is a touch driver 
installed, there may be a version conflict.  

 

If you check View/Options/General/Find Controller on Launch, the SDU will probe for 
the controller automatically when you start your system. The SDU displays driver details 
along with controller details in the “Poll” message box. (See Type/Poll) 

The SDU prefers to connect to a MT7 Software driver. If you have a controller on 
another port not connected to the driver, you will have to select the port manually. 

Close Active Port 
Close the active serial port. 

Find Controller 
Searches for controllers and lists all attached controllers. 

               
The Comm Port box indicates the type of controller found – either USB or serial. In some 
instances the search may be unsuccessful. 
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If you have more than one controller attached, you will see this screen – choose the 
controller you want. 

 

List Attached USB Devices 
Provides a list of all USB devices attached to the system. 
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CHAPTER 5 

View 

 

Toolbars 
Adds or removes the visible toolbar. 

Standard Tool Bar 

Shows the icons for SDU options along the standard toolbar. 

 

Show Text Labels 

Displays text labels under the SDU toolbar icons. 
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Status Bar 
Toggles the Status Bar on and off at the bottom of the active screen.  

 

Options 
Options include General, Terminal or Draw. 

General Options 

 

Find Controller on Launch -- If checked, the SDU looks for a USB driver, a Serial 
driver, and then a touch controller on any available COM port. The SDU tries to identify 
the controller. If a controller is found, details are displayed about the driver or the COM 
port, and the controller. 

Add Linefeeds to log file text for readability -- This option adds linefeeds (extra 
spaces) to the log file to increase readability. 

Terminal Options 
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Keep Terminal Open When Scope Opens -- Enables you to split the screen window to 
show both Terminal and Scope views.  

Data Display 

Line Wrap on CR (Hex Dump) or Point -- Customizes the way Terminal displays data. 
This is useful for breaking up the incoming Hex data into a more understandable format. 
Various packet formats often start with Bit 7 set and/or end with a carriage return (CR).  

 

Line Wrap on Bit 7 Set (Hex Dump) -- Use this option to display the hex dump data in 
an easy to read format. 

Full EXII XY Resolution -- Use this option to show the point data in format tablet in 
native EXII resolution. 

Show Timer and Absolute Timer -- Changes the way data is displayed in the window. 
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Draw Options 

 

The Draw window is often used as a measure of accuracy. A good test pattern is 
essential. It can be customized to suit your application. 

Show Grid -- The classic 8x8 line grid 

Show 25 point Targets -- The standard 5x5 linearization points with ±1 % crosses on 
center 

Draw Dots -- Shows only the points received, without line drawing to obscure data. 

Show Cursor -- Shows cursor as a cross as shown in the figure below. 

 

16 Point Prove Targets 

Show -- The traditional MT7 Software ‘prove’ points with ±1 % ellipses on center. 

Extended Targets -- Moves the ±1% ellipses closer to the edge of the sensor. 
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CHAPTER 6 

Format 

 

These options affect the way Draw and Terminal windows display point data.  

Undecoded 
Terminal shows non-printable ASCII characters as hex enclosed as: <00>. Used for line 
monitoring. 

MTS (FT, FD, FH) 
Toggle different formats – Format Tablet is the default format (FT), Format Decimal 
(FD), and Format Hex (FH).  Changing the Format does not send any commands or affect 
the way the controller actually sends data.  

For USB controllers, there is support for a ‘standard’ format when MTS is selected and 
also Cal Raw and HEX dump. 
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Hex Dump 
Terminal displays all received data as pairs of Hex characters. 

Enter Mode Pass Thru 
Reserved for DST touch systems 

Exit Mode Pass Thru 
Reserved for DST touch systems 

Mode Down/Up 
Reports touch down and lift off coordinates in USB only. 

 

Mode Poll 
System query for touch polling data. 

Switch to Tablet Mode 
Tablet mode is not available. 

Switch to HID Mode 
Support for HID controllers only 
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CHAPTER 7 

Data 

 

Controller Linearization Data 

X coefficients and Y coefficients  

The number grids show what data is presently stored in the controller.  

Apply  

Enables you to change settings  

Save to File 

Send 25-point data from controller to compare linearization in field to factory data 

Read from file 

Recreate issues from data settings collected in field 

Clear Buffer  

Erases all data in the buffer. Must scan barcode again to restore calibration data 

Decimal/hex 

Should default to hex mode 

Use this to compare linearization data by hand to barcode settings from factory. Read the 
first two coordinates from hex to compare to barcode data to verify accuracy. 
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In hex mode, the X and Y coefficients correspond to the 2D bar code label. 

Cable Linearization Data 
Show/load cable NOVRAM data stored. 
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CHAPTER 8 

Tools 

 

Calibration 
The traditional MTS extended calibration, always full-screen. This calibration will 
overwrite any previous 2 point calibration data. To cancel without calibrating, press 
escape. 
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If you have a Multitouch controller, the Calibration screen will have a white background 
rather than a black background. The functionality remains the same. 

Scope 

  

Scope is the most common tool for troubleshooting your touch system. This utility 
presents Format Raw corner data graphically as would a four channel digital 
oscilloscope.  
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Without touching the screen, if the Scope option shows equal noise distribution, this 
indicates that something is happening over the entire screen or bezel issue. If the data is 
not distributed evenly across all four corners, this could indicate a corner issue. 

Run 

Samples scope data.  

Stop 

Stops sampling scope data. 

Sum 

The SUM shows the noise. For example, with an EX controller, readings of less than 100 
(without touching the screen) typically indicates a quiet system. While a reading of 300 
typically indicates a noisy system.  

RST 

This option enables a soft reset of the controller. 

AC 

This option should be enabled. “On” displays the signals as offsets from 0. “Off” displays 
the signals as offsets from the stray values. 

VERT 

Vertical sweep is looking for noise – use the scale as needed for your test. It is common 
for touch sensing to be in the 10M range for an EX controller.  
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Sweep 

 

Log 

 

For EX controllers, you can select the Q and I quadrature drive and the R and P (Real 
and Phase) components for display. The four corners and the sum are displayed. 

 

Strays are sampled only at the start of the sweep, so it is desirable to have a faster sweep 
rate sometimes. 
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Haptic 

 

Test working condition of the controller without the Effect Selector loaded to see if 
actuators are working. 

Play Effect  

Number in box corresponds to effect number loaded in controller reference effect list in 
Chapter 8 of MCT Guide 

Play Effect Repeat  

Repeat effect “n” times of effect number selected in “Play Effect” 

Load Effect  

See Field Applications Engineer (FAE) for files and descriptions. 

Multitouch 

Full Screen Multi Draw 

This is the Draw screen supporting Multitouch.  A different colored line is assigned to 
each finger contact. 
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Graph  

Press the RAW button to start the display of the ambient levels on the sensor’s surface. 
Use the Single Row selector to show just one row at a time.   A typical, normally 
operating screen is shown.  It doesn’t have to be even across the surface, and the actual 
results will vary with the integration.  Obviously defective bars will show up as very low 
signals (height roughly half shown) in the Raw view.   

 

Press the COMP button to start the display of the touch levels on the sensor’s surface. 
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Uncheck the 3D box to get a 2D color-mapped view of either Raw or Compensated data. 
“COMP” shown with palm down on screen. 

 

Firmware Loader 

Press Select File to choose a binary image file (.bin) to load. This is only needed when 
testing new firmware from 3M Touch Systems. 
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When the file is selected, press “Send File to Controller”.   The software interacts with 
the controller’s bootloader to load the new firmware. When complete, the software will 
reboot the controller. 
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DST 

 

DST Q Parameters 

Enables all DST Q-parameters to be saved to a text file 

DST Default Parameters 

Enables updating default parameters on a controller.  Requires a default parameter file 

DST Parameter Restore Defaults 

Restores all parameters to default values 

DST Firmware Loader 

Updates firmware on controller with one provided in a file 

DST Firmware Copy to File 

Copies current controller firmware to a file 

DST Debug 

Enables collection of Get D (tap) and Get N (noise) data.   

DST Collector 

Enables collection of detailed debugging data in full screen mode.  Requires additional 
files 
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DST Collector (Template) 

Enables collection of detailed debugging data in window mode.  Requires additional files 

Barcode Scanner 

 

Open COM 1 

If you are using a serial barcode scanner, use this option to manually open the COM port 
if it doesn’t open automatically. 

Off 

This option disables the barcode scanner input and prevents any new data from 
downloading to the controller. 

USB Scanner Input Dialog 

This option enables you to scan data into the controller. A barcode text box appears. Scan 
barcode label. Hex data from the scanner scrolls across box.  The CLR button clears data 
from controller. 

Redirect to Cable 

Use this option to redirect the barcode data to the cable NOVRAM.  
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4 point Prove 
This option provides a quick scan of the 4 corners to ensure the 4 quadrants are 

operational. Touch once at each corner following the +.  

 

Linearize 
This option enables you to perform a full screen 25 point linearization. You must use the 
Software Diagnostic Utility to turn on “Linearize” option. By default, this option is not 
active because all systems are linearized at the factory. For more information, contact 
Technical Support or your Field Engineer. 

With certain controllers, you can perform a linearization to fine-tune your touch sensor. It 
should be performed only at the direction of 3M Touch Systems, Inc. Technical Support. 
Linearization consists of touching 25 targets on the screen followed by 16 additional 
points to determine specific point accuracy over the face of the display.  

The EX II, CX, and SC500-series touch controllers support Linearization: 

To test the accuracy of the linearization process, use the Draw program to draw some 
lines on the screen. Check that they are smooth, straight, and thin. You do not want lines 
to look keystoned or curved. 

To exit this program at any time during the process, press Escape. 
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Frequency 

 

This option adjusts the operating frequency of the touch controller. In general, you will 
not need to adjust the frequency. However, if you are experiencing problems with a 
jittery cursor, ragged lines, or random touch points, you may want to run the frequency 
option to check if there is noise in the system within the controller operating range. 

Use the Frequency option to test the available frequency settings and determine the best 
frequency. The range of frequency settings and the default setting depends on your touch 
controller. You can set a new operating frequency, and then check the performance of the 
touch sensor at that frequency setting. The cursor should hold steady and smooth. If you 
see erratic or jittery cursor movement, adjust the frequency until your touch test produces 
acceptable results. A good test is to go to the Draw program and hold your finger steady 
on the sensor. If the resulting pattern is a crisp and clear single dot, you should have a 
good frequency. 

It is recommended that you recalibrate the touch sensor after you run the Frequency 
option. 

With an EX controller, the default frequency is 95.7. Always try to select either one down 
(85.3) or one up (109) when changing frequency. Run a quick scan, if values are under 10 
you have a pretty clean system. Anything over 10 indicates a problem. 

Restore defaults to reset values to the factory settings. 

Loop 

Loop/Log looking for an event that is causing issues. This is the preferred tool for ‘best’ 
frequency selection and frequency spectrum scanning. You can let the scan loop 
continuously and log the results to a file. The results for each pass are presented in best to 
worst order. You are then prompted to accept or reject each pick. The continuous loop is 
intended to detect intermittent noise sources.  
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Log 

Tracks data in a log file so you can check for noise over a longer period of time. 

Quick Scan 

Runs and single time through the frequency values range. 

Limit Range 

This option enables you to reduce the scan range to specific values. 

Terminal 
This is the classic terminal mode offering decoding of different point output formats, as 
well as Hex dumps. Using the View > Options > Terminal menu, you can customize the 
appearance by adding a new line or space to the end of a point packet.  

Use the Format menu to select the point output formats. Note that the Format menu 
choices don’t tell the controller to output data in that format, they tell the SDU how to 
decode the format. Each point format has a different range to the data. The SDU displays 
touchdown points with a “D” and liftoffs with a “U” (up). Non printing bytes are shown 
in hex in brackets, for instance SOH, or 01 hex, is shown as <01>. A special indicator 
(“B”) is used for the touch pen barrel button, when in Format Tablet. 

Full Draw 

 

The Draw program lets you test the operation of the touch sensor and pen by checking the 
accuracy and speed with which the system responds to your touch. To draw, simply touch 
the sensor and drag your finger or pen.  
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You can customize the appearance with the View > Options > Draw tab, or right click for 
a context menu. See View > Options > Draw for details of these options. Draw can be 
displayed full screen or partial, but not both at the same time. The SDU paints a red + on 
touchdown and a cyan o on liftoff. Since Draw keeps a buffer, you can alternate the view 
options like dots and lines, while not losing the displayed data, at least up to the limits of 
the buffer. 

If you right click the mouse, an option menu appears that enables different views of the 
Draw screen.  

 

These options include: 
• Grid -- a uniform grid across the sensor  
• 16 pt -- 16 evaluation targets across the screen  
• Extended targets -- 16 points around the edge of the sensor  
• 25 point -- hash marks where the sensor is linearized  
• Dots -- does not link points in Draw format instead outpus raw single point data 

values as if liftoff had taken place 

Since Draw is traditionally a full-screen keyboard-only application, there are several 
keyboard commands supported: 
 
Space   Clear Screen 
B  grid off (Blank) 
G  Grid on 
R sends soft Reset to controller 
S toggle extended calibration points 

Use the Format menu as required for displaying standard MTS formats, Cal Raw, or 
foreign controller formats. 

Note that for Format Decimal, the default format for controllers, the factory standard 
mode does not indicate touch up or down. Draw will send an MT (mode status command) 
only once in order to turn on the up/down status header.  

If you unplug a controller in this mode, the status mode will reset and Draw won’t draw, 
but Terminal will show point packets starting with <01>. 

Template Draw 
Draw template style. This shows a grid within a window instead of taking up a full 
screen. 
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Split Mode 
The Draw and Terminal screens are shown opened side by side (note that if you’re using 
the traditional keyboard commands for Draw, keyboard input is directed to the active 
window).  

 

EXII Firmware Loader 
This option enables you to load new firmware into the controller by clicking on “Select 
File”. You may then point to a new firmware hex file from 3M Touch Systems. 

You can also save the existing firmware file from the controller into a new location on 
your computer. This is a useful option if you are testing new firmware and want to retain 
a copy of the existing firmware. This copies the existing firmware hex file to a location 
specified by you.  

Reboot EEPROM 
This option enables you to reboot the controller’s EEPROM. 

Restore Defaults 
This option enables you to restore the controller factory default settings. Note that you 
must perform a calibration after restoring controller defaults.  



40 3M™ MicroTouch™ MT7 Software Diagnostic Utility User Guide 

 

3M Touch Systems, Inc. Proprietary Information 

Soft Reset 
This command initializes the hardware and the firmware, causes the controller to stop 
sending data, and recalculates the environmental conditions (for example, stray and offset 
values). The Reset command also cancels existing commands and returns the controller 
to normal operation.  

Hard Reset 
This option will restore supplier factory configuration settings. If none exist, it will reset 
to 3M Touch System defaults. 

Grid Maker 
This option enables you to create a grid pattern that can be printed and placed under the 
sensor for testing purposes when the sensor is not mounted to an LCD. 

Video Testing 
The color bars option allows you to verify the standard display colors in 1024x768 
resolution. 

Color Cycle 

This option shows full screen color samples in red, green, blue and white. 
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CHAPTER 9 

Type 

 

You can use the menu radio buttons to select the controller type manually. Some tools 
need to know the controller type in order function properly.   

Poll 
Presents information for the currently attached controller and driver. 

Select Pen 
Selects touch pen input. 

Select Finger 
Select finger input. 

Select Auto 
Selects touch pen auto input. 
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CHAPTER 10 

Reports 

 

Strays Report 
For EX and CX controllers, this option measures the stray capacitance values at each 
channel. Use this report to provide system information to a Field Engineer or Technical 
Support. These values can also be used by advanced users when comparing multiple 
system integrations and trying to reduce stray capacitance. 
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Frequency Report 

 

For EX controllers, the default choice for frequency setting is 95.7 kHz. If the display 
noise is high at this setting, you may try other frequencies to reduce the effects of noise 
on touch performance – 109 kHz and 76 kHz have been tested.  

Sensitivity 
This option allows you to adjust the touch threshold of the system. By default, this option 
is not active since the optimal setting for each controller is established at the factory. For 
more information, contact Technical Support or your Field Engineer. 

Controller ID 
This option enables you to check or set the Controller ID. This is required in multiple 
sensor system setup situations. 

   

Orientation 
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The standard screen orientation and tail exit is 3:00. A calibration can rotate the 
orientation for other tail settings. 

Screen RC 
This is a diagnostic tool used exclusively for SCxxx controllers.  
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CHAPTER 11 

Window 

 

Cascade 
Cascade open windows within the SDU 

Tile Horizontal  
Tile open windows within the SDU horizontally 

Tile Vertical 
Tile open windows within the SDU vertically 

Close 
Close current window within the SDU  

Close all  
Closes all open windows within the SDU. 
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CHAPTER 12 

Help 

 

About MT7 SDU 
This option provides version information to enable support personnel to determine 
whether you are using the latest version of this tool. 

 

 


